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Abstract

KWordQuiz is a flashcard and vocabulary learning program for KDE.
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Chapter 1

Introduction

KWordQuiz is a tool that gives you a powerful way to master new vocabular-
ies. It may be a language or any other kind of terminology.

1.1 Easy to use

With KWordQuiz you build your own vocabulary documents in a simple and
intuitive way. The basic layout is a two-column spreadsheet where you type
vocabulary entries in one form that you know and in another form that you
want to learn. You change the titles of the columns to reflect what you are
practicing.

1.1.1 Practice modes

Before you start a quiz you select how you want to practice. KWordQuiz offers
five different modes to make practicing more efficient. The different modes
make it possible to have the quiz go through your vocabulary in sequential or
random order in one or both directions.

1.1.2 Quiz types

When you have entered your vocabulary and selected a mode you are ready to
start a quiz. The vocabulary document is hidden during the quiz so you cannot
cheat. Maybe you want to start with a flashcard session, then you can move
on to a multiple choice quiz or do the powerful question and answer quiz. You
get instant feedback on correct and incorrect answers and you have the option
to repeat any errors, further improving your learning efficiency. If you need a
little extra help you can use the hint function.
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1.1.3 Vocabulary documents

KWordQuiz can open several types of vocabulary data. Supported are .kvtml
used by other KDE programs such as KVocTrain, .wql used by WordQuiz for
Windows R©, .csv files with comma-separated text, and .xml.gz files created by
Pauker (http://pauker.sourceforge.net). You can automatically combine sev-
eral documents to one large list if you need to practice for e.g. a final exam.

KWordQuiz can save your vocabulary documents several different formats.
The default is the .kvtml format used by other KDE programs. Other avail-
able options are the .wql format used by WordQuiz for Windows R© allowing
exchange with Windows R© users, .csv, and .html.

You can have several files open at the same time and easily copy or move en-
tries between files.
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Chapter 2

Command Reference

2.1 The File Menu

File→New (Ctrl+N) New creates a new blank vocabulary document

File→Open... (Ctrl+O) Open one or more existing vocabulary documents.
Several documents can be combined to one larger list.

File→Open Recent Open a recently used vocabulary document

File→Get New Vocabularies... (Ctrl+G) Downloads new vocabularies.

File→ Save (Ctrl+S) Save the active vocabulary document to disk

File→ Save As... Save the active vocabulary document with a new name

File→ Print... (Ctrl+P) Print the active vocabulary document. KWordQuiz
provides several options for printing your vocabularies.

File→ Close (Ctrl+W) Close the active vocabulary document

File→Quit (Ctrl+Q) Quit KWordQuiz

2.2 The Edit Menu

Edit→Undo (Ctrl+Z) Undo the last command. The name of this item will
change to reflect what will be undone.

Edit→ Cut (Ctrl+X) Cut the current selection and place it on the clipboard

Edit→ Copy (Ctrl+C) Copy the current selection and place it on the clip-
board
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Edit→ Paste (Ctrl+V) Paste the content of the clipboard to the current selec-
tion. If only one cell is selected KWordQuiz will activate smart pasting
and calculate the space required for pasting and add rows if necessary.

Edit→ Clear Clear the current selection

Edit→ Insert Row (Ctrl+I) Insert a new row at the current selection. If the
selection extends over more than one row, an equal number of rows will
be inserted.

Edit→Delete Row (Ctrl+K) Delete the selected row. If the selection extends
over more than one row, all selected rows will be deleted.

Edit→Mark as Blank (Ctrl+M) Mark as Blank marks selected text (or the
word where the caret is) as a blank for a ’Fill-in-the-blank’ quiz, i.e. it’s
enclosed in brackets. Only available if Fill-in-the-blank is enabled.

Edit→Unmark Blanks Unmark Blanks clears previously assigned blanks,
i.e. brackets are removed. Only available if Fill-in-the-blank is enabled.

2.3 The Go to Menu

Go to→ Editor (F6) Activate the vocabulary editor

Go to→ Flashcard (F7) Start a flashcard session

Go to→Multiple Choice (F8) Start a multiple choice quiz

Go to→Question & Answer (F9) Start a question & answer quiz

2.4 The Vocabulary Menu

Vocabulary→ Column Titles... (Ctrl+L) Define the titles of the two columns
in the vocabulary. Displays a dialog.

Vocabulary→ Font... Change the font used to display the vocabulary. If you
are in flashcard session the font used to diplay the card will be changed.
Displays the standard KDE font dialog.

Vocabulary→ Rows/Columns... Specify the number of rows in the vocabu-
lary, or define the height of selected rows or the width of selected columns.
Displays a dialog.

Vocabulary→ Sort... Sort the vocabulary entries. Displays a dialog.

Vocabulary→ Shuffle Shuffle the vocabulary entries in a random order

4



The KWordQuiz Handbook

2.5 The Mode Menu

The menu provides five different modes for the quiz.

Note that the menu names will change to reflect the column titles of the cur-
rently active vocabulary document. The mode must be selected before a quiz
is started. The selected mode will apply to Flashcard, Multiple Choice and
Question & Answer.

Mode→ Column 1 -> Column 2 In Order During the quiz you will be given
the entries of Column 1 and asked to provide the corresponding Column
2 entries. This will be done in the order the entries appear in the vocabu-
lary document.

Mode→ Column 2 -> Column 1 In Order During the quiz you will be given
the entries of Column 2 and asked to provide the corresponding Column
1 entries. This will be done in the order the entries appear in the vocabu-
lary document.

Mode→ Column 1 -> Column 2 Randomly During the quiz you will be given
the entries of Column 1 and asked to provide the corresponding Column
2 entries. This will be done in a random order, but each entry will be
asked once.

Mode→ Column 2 -> Column 1 Randomly During the quiz you will be given
the entries of Column 2 and asked to provide the corresponding Column
1 entries. This will be done in random order, but each entry will be asked
once.

Mode→ Column 1 <-> Column 2 Randomly During the quiz you will be given
an entry of either Column 1 or Column 2 and asked to provide the corre-
sponding entry in the other column. This will be done in a random order
for both column and entry. Each possible combination will be asked once.

2.6 The Quiz Menu

Quiz→ Check (Return) Check if your answer is correct

Quiz→ I Know (K) Count as correct during a flashcard session.

Quiz→ I Do Not Know (D) Count as error during a flashcard session. You
can later repeat these cards by selecting Quiz→ Repeat Errors.

Quiz→Hint (Ctrl+H) Get the next correct letter during a Question & An-
swer session.

Quiz→ Restart (Ctrl+R) Restart the quiz session from the beginning. Will
reset the scores.

Quiz→ Repeat Errors (Ctrl+E) Repeat any questions you answered incorrectly.
Becomes available once you have answered all questions once.
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2.7 The Settings Menu

Settings→ Toolbars→Main Toolbar (KWordQuiz) Toggle the Main Toolbar

Settings→ Toolbars→Go to (KWordQuiz) Toggle the Go to Toolbar

Settings→ Toolbars→Quiz (KWordQuiz) Toggle the Quiz Toolbar

Settings→ Toolbars→ Special Characters (KWordQuiz) Toggle the Special
Characters Toolbar

Settings→ Show/Hide Statusbar Toggle the Statusbar

Settings→ Configure Shortcuts... Configure the keyboard keys you use to
access the different actions.

Settings→ Configure Toolbars... Configure the items you want to put in the
toolbar

Settings→ Configure Notifications... Configure notifications for certain events
in KWordQuiz

Settings→ Configure KWordQuiz... Configure preferences for the vocabu-
lary editor and the quizzes. Displays a dialog.

2.8 The Help Menu

Help→KWordQuiz Handbook (F1) Invokes the KDE Help system starting
at the KWordQuiz help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KWordQuiz will
open a help window (if one exists for the particular item) explaining the
item’s function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→About KWordQuiz This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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Chapter 3

The Vocabulary Editor

The vocabulary document area has the appearance of a spreadsheet-like grid.
The grid consists of cells organized in two columns and a number of rows.
Each column and row has a header. The column headers are used to specify
the titles of the vocabulary document. They can be set by selecting Vocabulary
→ Column Titles.... The row headers number the rows consecutively.

You can click in a cell of the grid to make it the active cell. You can select several
cells for copying or other editing by dragging over them with the left mouse
button down. To select entire rows or columns click in the headers.

In the document you build a vocabulary of pair-wise entries in the two columns.
You can enter text into the active cell simply by starting to type. The cell will
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now be in edit mode and you can select all or part of the text. You can also edit
a cell by double-clicking it or pressing F2 and make changes directly in the cell.

When you have finished typing one entry, press the return key and the next
cell will automatically become active. Hence, it’s easy to quickly type several
entries. You can customize this behavior by selecting Settings→ Configure
KWordQuiz.... When you reach the bottom row of the grid, a new row will
be added as you press return, so you can just continue to type. When a new
window is created it has 50 rows, but there is really no limit to the number of
rows you can have in a document.
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Chapter 4

Flashcard Session

Select Go to→ Flashcard to start a flashcard session on the entries of the active
vocabulary document. The mode selected in the Mode menu will be used. If
you change mode during a session, the session will be restarted.

If you are working with long expressions the window can be resized to make
more space available. The font size will also influence how much will fit in the
different parts of the window. By selecting Vocabulary→ Font you can specify
the font used for the flashcards.
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Initially the front of the card is displayed. Use Quiz→ Check to see the other
side.
To move on to the next card either select Quiz→ I Know to count the card as
correct or QuizI Don’t Know to count the card as incorrect.

Select Quiz→ Repeat Errors to repeat the cards you have counted as incorrect.

Select Quiz→ Restart to start the session from the beginning again. If you are
using a random mode the cards will be reshuffled.

The score sections at the bottom of the screen shows the number of cards, the
number of cards you have seen, the number of cards counted as correct, and
the number counted as incorrect.

TIP
All items on the Quiz menu are available on the Quiz toolbar that is displayed on
the right by default.
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Chapter 5

Multiple Choice Session

Select Go to→Multiple Choice to start a multiple choice quiz on the entries in
the active vocabulary document. The mode selected in the Mode menu will be
used. If you change mode during a session, the session will be restarted.

If you are working with long expressions the window can be resized to make
more room. The font size (selected for the editor) will also influence how much
will fit in the different parts of the window.

In the example below the user gave an incorrect answer to the previous ques-
tion. He/she is now about to answer the next question.
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Your choices are shown on the top left. Select the one you think is correct. Use
Quiz→ Check to see if the answer is correct. If you have activated the auto-
matic mode in Settings→ Configure KWordQuiz... your selection is checked
immediately.

The previous question is shown below the current. The answer you gave is
also displayed. If you answered incorrectly the correct answer is shown.

Select Quiz→ Repeat Errors to repeat the questions you answered incorrectly.

Select Quiz→ Restart to start the session from the beginning again. If you are
using a random mode the questions will be reshuffled.

The score sections at the bottom of the screen shows the number of questions,
the number of questions you have answered, the number of correct answers,
and the number of incorrect answers.

TIP
All items on the Quiz menu are available on the Quiz toolbar that is displayed on
the right by default.
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Chapter 6

Question & Answer Session

Select Go to→Question & Answer to start a question & answer session on the
entries in the active vocabulary. The mode selected in the Mode menu will be
used. If you change mode during a session, the session will be restarted.

If you are working with long expressions the window can be resized to make
more room. The font size (selected for the editor) will also influence how much
will fit in the different parts of the window.

In the example below the user gave a correct answer to the previous question
(to see how incorrect answers are handled, see the Multiple Choice chapter).
He/she is now about to answer the next question.
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Your question is shown on the top left. Type your answer in the edit field. Use
Quiz→ Check or Enter to see if the answer is correct.

The previous question is shown below the current. The answer you gave is
also displayed. If you answered incorrectly the correct answer is shown.

Select Quiz→ Hint to get the next correct letter of the answer. In Settings→
Configure KWordQuiz... you can select that questions where you use the hint
function are always counted as incorrect.

Select Quiz→ Repeat Errors to repeat the questions you answered incorrectly.

Select Quiz→ Restart to start the session from the beginning again. If you are
using a random mode the questions will be reshuffled.

The score sections at the bottom of the screen shows the number of questions,
the number of questions you have answered, the number of correct answers,
and the number of incorrect answers.

TIP
All items on the Quiz menu are available on the Quiz toolbar that is displayed on
the right by default.
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Chapter 7

Fill-in-the-blank

’Fill-in-the-blank’ is a powerful way to practice in KWordQuiz. It is a special
kind of question and answer quiz that needs to be described in more detail. In
order to use this feature you must turn it on in the configuration dialog.

Consider the following table. It could be a vocabulary in KWordQuiz:

English German

1 We own a computer Wir besitzen einen
Computer

2 We own a computer Wir [besitzen] einen
Computer

3 We own a computer Wir [besitzen einen]
Computer

4 We own a computer Wir [besitzen] einen
[Computer]

The important thing to note is the placement of the brackets. They tell KWordQuiz
how the quiz should be performed.

In 1. there are no brackets. Assuming English is the question and German the
answer you have to give the entire expression ’Wir besitzen einen Computer’
for a correct answer.
In 2. KWordQuiz would display the question but also ’Wir ........ einen Com-
puter’. For a correct answer it is sufficient to write ’besitzen’.

3. shows that a blank can consist of more than one word. The correct answer is
’besitzen einen’.
In 4. there are two separate blanks. To specify that in the answer you have to
write ’besitzen; Computer’, i.e separate the blanks with a semicolon in order
to get a correct answer.
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Marked blanks are only of relevance if they appear in the answer. Otherwise
the brackets are ignored. Furthermore, brackets have no effect in multiple
choice quizzes. To simplify the creation of ’Fill-in-the-blank’ vocabularies there
are toolbar and menu commands to mark and unmark blanks. Of course you
can also just type the brackets. KWordQuiz checks the syntax. If the text ap-
pears in red there is something wrong with the brackets and a quiz cannot be
started.
The ’Fill-in-the-blank’ features can be turned on and off in the Options dialog.
Turning them of will make it possible to use fonts that map other characters to
the positions of the brackets. It will also speed up performance slightly.
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Chapter 8

Printing

KWordQuiz provides the ability to print vocabulary documents in several dif-
ferent ways. When selecting File→Print... you are presented with the standard
KDE print dialog. In order to get access to the special KWordQuiz features you
need to click on the Options» to see the Vocabulary Options tab. On this tab
you can select to print the document as a vocabulary list (i.e. as displayed in
the editor), a vocabulary exam, or as flashcards.
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Vocabulary list The vocabulary will be printed as displayed in the editor. This
includes font, row heights, and column widths. Make sure that the columns
are narrow enough to fit on the page.
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Vocabulary exam The vocabulary will be printed as displayed in the editor,
except that the right column will be left empty and a third column for scoring
is added. Settings used include font, row heights, and column widths. Make
sure that the columns are narrow enough to fit on the page.

Flashcard Two 3" x 5" cards per page. The cards will always be printed in
landscape.
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Chapter 9

Dialogs

9.1 Configure Editor

You can configure the behavior of the Enter key when working in the editor.
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You can also select if the functions for Fill-in-the-blank should be activated.
Turning them off will speed up performance a little.

Select Defaults to restore all settings to predefined defaults. Select Apply to
make your changes without closing the dialog. Select OK to make your changes
and close the dialog. Select Cancel to close the dialog without making any
changes.

9.2 Configure Quiz

For flashcard sessions you can select if the cards should be flipped automati-
cally, and if they should be counted as correct or incorrect. Enter a time delay
in seconds for the automatic flipping.

For multiple choice sessions you can select if your choice should be checked
immediately or if you have to select Quiz→ Check first.

For question & answer sessions you can select if questions where you use Quiz
→Hint should be counted as incorrect.
For all sessions you can select if the scores should be displayed as percent in-
stead of absolute numbers.
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Select Defaults to restore all settings to predefined defaults. Select Apply to
make your changes without closing the dialog. Select OK to make your changes
and close the dialog. Select Cancel to close the dialog without making any
changes.

9.3 Configure Flashcard Appearance

For flashcard sessions you can select the Font: and the colors of text, card and
frames. Click the Flip to switch between the Front and the Back of the cards.

Select Defaults to restore all settings to predefined defaults. Select Apply to
make your changes without closing the dialog. Select OK to make your changes
and close the dialog. Select Cancel to close the dialog without making any
changes.

22



The KWordQuiz Handbook

9.4 Configure Special Characters

Nine configurable actions are available for insertion of special characters into
the vocabulary. Select one of the actions in the list and then click the Character...
button to select a character for that action. A larger preview of the current
character is displayed.

Changing the keyboard shortcut associated with each action can be done by
selecting Settings→ Configure Shortcuts....

Select Defaults to restore all settings to predefined defaults. Select Apply to
make your changes without closing the dialog. Select OK to make your changes
and close the dialog. Select Cancel to close the dialog without making any
changes.
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9.5 Column Titles

Use this dialog to define the column titles of the vocabulary. Select OK to make
your changes or Cancel to discard any changes.

9.6 Special Characters

Use this dialog to select any special character you want to associate with the
current special character action.
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9.7 Rows/Columns

Use this dialog to specify the number of rows you want in the vocabulary. You
can also adjust the width (in pixels) of the selected columns and the height
(in pixels) of the selected rows. Select OK to make your changes or Cancel to
discard any changes.

WARNING
Specifying a number of rows lower than what currently is in the vocabulary may
lead to loss of data.
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9.8 Sort

Use this dialog to sort the vocabulary alphabetically. You can specify if the sort
should be based on the left (French in this example) or right (English in this
example) column and if it should be in ascending or descending order. Select
OK to do the sort or Cancel to leave the vocabulary unchanged.
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Chapter 10

Questions and Answers

This document may have been updated since your installation. You can find
the latest version at http://docs.kde.org/development/en/kdeedu/ .

1. Can I combine several vocabularies to one.
Yes, when you select File→Open... you can highlight more than one file
in the dialog. By default they will be opened in separate windows, but if
you select the check box Join selected files into one list, then the data in
all files will be combined into one new list.
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Chapter 11

Credits and License

KWordQuiz

Program copyright 2003-2004 Peter B. Hedlund peter.hedlund@kdemail.net

Documentation copyright 2003-2004 Peter B. Hedlund peter.hedlund@kdemail.net

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain KWordQuiz

KWordQuiz is part of the KDE project http://www.kde.org/ .

KWordQuiz can be found in the kdeedu package on ftp://ftp.kde.org/pub/-
kde/ , the main FTP site of the KDE project.

A.2 Compilation and installation

In order to compile and install KWordQuiz on your system, type the following
in the base directory of the KWordQuiz distribution:

% ./configure
% make
% make install

Since KWordQuiz uses autoconf and automake you should have no trouble
compiling it. Should you run into problems please report them to the KDE
mailing lists.

29

http://www.kde.org/
ftp://ftp.kde.org/pub/kde/
ftp://ftp.kde.org/pub/kde/

	Introduction
	Easy to use
	Practice modes
	Quiz types
	Vocabulary documents


	Command Reference
	The File Menu
	The Edit Menu
	The Go to Menu
	The Vocabulary Menu
	The Mode Menu
	The Quiz Menu
	The Settings Menu
	The Help Menu

	The Vocabulary Editor
	Flashcard Session
	Multiple Choice Session
	Question & Answer Session
	Fill-in-the-blank
	Printing
	Dialogs
	Configure Editor
	Configure Quiz
	Configure Flashcard Appearance
	Configure Special Characters
	Column Titles
	Special Characters
	Rows/Columns
	Sort

	Questions and Answers
	Credits and License
	Installation
	How to obtain KWordQuiz
	Compilation and installation


