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Abstract

KVerbos is an application specially designed to study Spanish verbforms.
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Chapter 1

Introduction

With KVerbos the user can learn the forms of Spanish verbs. The program sug-
gests a verb and a time and the user enters the different forms. The program
corrects the user input an gives a feedback. The user can edit the list of the
verbs that can be studied. The program can built regular verb forms by itself.
Irregular verb forms have to be entered by the user. If a form of a verb is un-
certain then the internet offers good sources: http://csgrs6k1.uwaterloo.ca/-
dmg/lando/verbos/con-jugador.html

The most interesting feature in the recent release is the use of KFeeder. This
is a separate program that the user has to install separately if he wants to use
it. If it is installed then the learning progress will be shown in the KFeeder
application. A dog is running around and will be fed with bones if you are a
good learner. Otherwise he will be lying around most of the time.
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Chapter 2

Using KVerbos

When the user starts the program he can see this window. This is the main
window of the application where the user can train verb forms. At the moment
no verb file is loaded. So the program cannot suggest a verb. First the user has
to open a file either with the menu File→Open or with the menubar or he has
to enter some verbs with Edit→ Enternew verb.
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Once the user has opened a file with verbs the program suggests one of them
and a time. The user can type the solution into the textboxes.

This button wipes out all user input.

The user can test his input with this button. In-
correct forms will be underlined. Then the user has the chance to do it
better and correct the forms another time. If one of the forms wasn’t cor-
rect the verb cannot be counted as correct anymore.

If the user wants to see the solution he can use
show solution. Then the correct solution is displayed in the editboxes. If
the user uses this button the verb cannot be counted as correct anymore.

The last button in this row can have two func-
tions.
If the user presses this button and the verb forms haven’t been corrected
yet the button behaves like the ’corregir’ button. The verb forms are cor-
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rected and the user can see if his input was correct. If the user wants to
go on he has to press the button again.
If the button is pressed and the verbs already have been corrected the
program goes on to the next verb. That means another verb is selected
and presented to the user.

A second line of buttons
allows the user enter special spanish characters which probably cannot be en-
tered by keyboard.

In the status bar of the program the user gets information about his work. He
can see how many verbs he has trained and how many of them have been
correct. He can see how many verbs are stored in the opened file and which
username has been entered, too.

The progress bar is another feedback for the user. He can see his correct an-
swers as a percentage of trained verbs.
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Chapter 3

Command Reference

3.1 The main KVerbos window

3.1.1 The File Menu
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File→New (Ctrl+N) Creates a new document. That means that the verbs in
the actual list are deleted. The number of verbs is set to 0.

File→Open (Ctrl+O) Opens a verb file. The file dialog opens and the user
can select one of the verb files. The user has to make sure, that it is a verb
file. There isn’t a default verb file that comes with the program. The user
has to enter his own verbs or he has to download a verb file from the
KVerbos website.

File→Open Standard Verb File Opens a verb file that is delivered with KVer-
bos. The user can use this file if he doesn’t want to enter his own verbs.

File→ Save (Ctrl+S) Saves the document. The file name dialog opens and the
user can choose a name for the verb file. If the file name end with .htm or
.html the verb list is saved as a HTML file.

File→ Save As Saves the document. The file name dialog opens and the user
can choose a name for the verb file. If the file name end with .htm or
.html the verb list is saved as a HTML file.

File→ Close (Ctrl+W) Terminates the program.

File→New Window Starts a new instance of the program.

File→Quit (Ctrl+Q) Quits KVerbos

3.1.2 The Edit Menu

Edit→ Enter new verb Opens the dialog new verbs where you can add new
verbs to the verb list. This dialog is described in another chapter of this
documentation.

Edit→ Edit verblist Opens a dialog with a list of all the verbs that are in the
actual verb list. You can edit this verb list. This dialog is described in
another chapter of this documentation.

3.1.3 The User Menu

User→ username Opens a small dialog where you can enter your username.

User→ results Opens a dialog where a user can see the number of training
sessions he has done with the program and the latest ten results.

3.1.4 The Settings Menu

Settings→ Show toolbar The user can decide whether he wants to see the
toolbar or not. He can set it here.

Settings→ Show statusbar The user can decide whether he wants to see the
status bar or not. In the status bar are shown information like the number
of trained verbs and the user name.
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Settings→ options Opens a dialog where a user can select the times he wants
to train and the correction mode. More details see the chapter about this
dialog.

3.1.5 The Help Menu

Help→KVerbos Handbook (F1) Invokes the KDE Help system starting at
the KVerbos help pages. (this document).

Help→What’s This? (Shift+F1) Changes the mouse cursor to a combination
arrow and question mark. Clicking on items within KVerbos will open a
help window (if one exists for the particular item) explaining the item’s
function.

Help→ Report Bug... Opens the Bug report dialog where you can report a
bug or request a ‘wishlist’ feature.

Help→About KVerbos This will display version and author information.

Help→About KDE This displays the KDE version and other basic informa-
tion.
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3.2 The New Verb Dialog

Use this dialog if you want to make your own verb list or if you want to append
some new verbs to an existing verb list. Here you can enter the infinitive of the
spanish verb and its meaning in a foreign language. Important is, that you
tell the program if it is a regular verb or one of the spanish group verbs or
an irregular one. If it is irregular you have to enter the irregular forms, too.
Be careful with this dialog and the verb forms you enter because the program
uses this data to generate forms automatically.

Some of the Edit boxes where you can enter the verb information. There
are similar Edit Boxes for the gerund and participle form and all the other
forms if needed.
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With this Combo Box you select which
type of verb you have entered. Do this carfully because it is important in-
formation for the program to do its work properly.
The Spanish language knows three types of regular conjugation. These
are the conjugation pattern for the verbs ending on -er, -ar, and -ir. A lot
of verbs are not regular in all forms but they aren’t completely irregular.
This verbs are called group verbs and can be divided in several groups.
The program can generate the forms for the regular verbs and the ones
for the group verbs itself. It only needs the information to which group
the verb belongs. Other verbs are irregular and the irregular forms have
to be entered. Select the group in the Combo Box.

regular Chose this if it is a completely regular verb of one of the patterns
-ar, -er or -ir.

irregular Select this if the verbs doesn’t belong to one of the groups de-
scribed below. The Tab View will be activated and you can enter all
the irregular forms.

e > ie Chose this for stem changing verbs where the e in the stem changes
to ie.

o > ue Chose this for stem changing verbs where the o in the stem changes
to ue.

u > ue Chose this for stem changing verbs where the u in the stem changes
to ue.

e > i Chose this for stem changing verbs where the e in the stem changes
to i.

c > qu A verb with orthografic irregularity. If a ‘c’ comes before an ‘e’
the ‘c’ changes to ‘qu’. Examples: colocar, atacar

g > gu A verb with orthografic irregularity. If a ‘g’ comes before an ‘e’
the ‘g’ changes to ‘gu’. Example: pagar

z > c A verb with orthografic irregularity. If a ‘z’ comes before an ‘e’ the
‘z’ changes to ‘c’. Examples: cazar, alzar
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gu > gu A verb with orthografic irregularity. If a ‘gu’ comes before an ‘e’
the ‘gu’ changes to ‘gu’. Example: averiguar

c > z A verb with orthografic irregularity. If a ‘c’ comes before an ‘o’ or
‘a’ the ‘c’ changes to ‘z’. Examples: vencer, zurcir

g > j A verb with orthografic irregularity. If a ‘g’ comes before an ‘o’ or
‘a’ the ‘g’ changes to ‘j’. Examples: coger, dirigir

gu > g A verb with orthografic irregularity. If ‘gu’ comes before an ‘o’ or
‘a’ the ‘gu’ changes to ‘g’. Example: distinguir

qu > c A verb with orthografic irregularity. If ‘qu’ comes before an ‘o’ or
‘a’ the ‘qu’ changes to ‘c’. Example: delinquir

accent like ‘enviar’ A verb where the accent changes in some forms. Ex-
ample: enviar

accent like ‘continuar’ A verb where the accent changes in some forms.
Example: continuar

missing i Some verbs lose the instressed ‘i’ in some forms. Examples:
taner, grunir, bullir

If you enter an irregular verb the tab view will be activated and you can
select the tab with the irregular forms.

You have entered some incorrect informa-
tion and want to delete them. With this button you can wipe out the data
in the Edit box of one single tab.

This but-
tons insert the displayed spanish characters to the Edit box that has the
focus. Often these characters cannot be entered with the keyboard.

You want to wipe out all information in all Edit
Boxes on all tabs. Then use this button.

Selects the verb before the actual verb in the verb list
into the dialog. You can read an change the information for this verb. If
the actual verb is the first one then the last one is loaded into the dialog.

Selects the verb behind the actual verb in the verb
list into the dialog. You can read an change the information for this verb.
If the actual verb is the last one then the first one is loaded.
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Closes the dialog and returns to the main program or
the Edit Verblist Dialog depending from where the dialog was opened.

3.3 The Edit Verblist Dialog

In the list view of this dialog you can see all the verbs of the opened verb file.
If there aren’t any verbs in the file or if there isn’t a file open the list view will
be empty. You can select a verb from the list and edit this verb or you select
and delete one of them.

This button deletes the selected verb from the list of
verbs.
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With this button you can leave the dialog. All changes
that have been made until this moment will not affect the verb list of the
main program. That means that the list of the main program will be un-
changed.

The selected verb will be edited. The new verb dialog
opens and the selected verb is loaded to the edit boxes. You can make
your changes. If you make a double click on a verb this has the same
effect than this button.

With this button you can close the dialog. The changes
that have been made are stored in the verb list of the main program.

3.4 The Username Dialog

Enter your name here. The name is set as the new username of the program.
It will be displayed in the programs status bar. Use the OK Button to confirm
your input. The Cancel button leaves the user name unchanged.

The program will store some information about your learning progress. The
number of training sessions, the result of the last ten sessions and lists with the
verbs that you entered right or wrong recently.

You can have a look at this information in the User→ Results dialog.
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3.5 The User Result Dialog

In this dialog you can see the information that the program stores about you
under your username. On the left you can see the results of the latest ten ses-
sions and on the right are lists with the word that you entered right or wrong
recently. A verb remains in the list of the right verbs for some time then it
changes to the status unlearned again. The verbs that are in the wrong list will
appear more frequently. They stay in the list until you enter them correctly.
Then they will return to the list of the unlearned verbs.
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3.6 The Settings Options Dialog
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In this dialog you can select the tenses that should be trained. So if you want
to study a specific tense or if you haven’t learned how to build the forms of a
specific tense yet so you can select or deselect the tenses here. Your selection is
stored to the properties file of the program.

You can select a correction mode too. If you select correct strictly then every
missing accent is regarded as an error. You can make it easier with ignore
accent then a missing accent isn’t an error.

At last you can control the use of KFeeder if this application is installed. You
can decide if the learning results will be shown with KFeeder, if the splash
screen can be seen when the program is starting and what type of food anima-
tions are used. The last points needs a further explanation. KFeeder displays
an animal that is running around. When you enter a correct solution your
points will be send to KFeeder. The dog gets bones for each point. If you chose
move food automatically then the bones move down from the ceiling and one
point is one bone. Otherwise every point is only a move for a bone. So you will
need more points until the dog can reach the bone. Really the option move food
automatically is more interesting.
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Chapter 4

Developer’s Guide to
KVerbos

At the moment it is not possible to program any plugins for KVerbos.
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Chapter 5

Questions and Answers

This document may have been updated since your installation. You can find
the latest version at http://docs.kde.org/development/en/kdeedu/ .

Until now nobody had a question that could be answered here.
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Chapter 6

Credits and License

KVerbos
Program Copyright 2002 Arnold Kraschinski arnold.k67@gmx.de

Documentation Copyright 2002 Arnold Kraschinski arnold.k67@gmx.de

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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Appendix A

Installation

A.1 How to obtain KVerbos

KVerbos is part of the KDE project http://www.kde.org/ .

KVerbos can be found in the kdeedu package on ftp://ftp.kde.org/pub/kde/
, the main FTP site of the KDE project.

A.2 Requirements

In order to successfully use KVerbos, you need KDE 3.x.x. The program is
distributed without a verblist file. So you have to enter the verbs yourself or
you can download a verbfile.

A verblist file and KVerbos itself can be found on The KVerbos home page.

You can find a list of changes at http://edu.kde.org/kverbos/ .

A.3 Compilation and Installation

In order to compile and install KVerbos on your system, type the following in
the base directory of the KVerbos distribution:

% ./configure
% make
% make install

Since KVerbos uses autoconf and automake you should have no trouble com-
piling it. Should you run into problems please report them to the KDE mailing
lists.
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