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Abstract

Kiten is a Japanese reference/study tool for KDE.
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Chapter 1

Introduction

Kiten is an application with multiple functions. Firstly, it is a convenient En-
glish to Japanese and Japanese to English dictionary; secondly, it is a Kanji
dictionary, with multiple ways to look up specific characters; thirdly, it is a tool
to help you learn Kanji.

Each of these modes is discussed in its own chapter.
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Chapter 2

Using the Dictionary

Kiten’s most basic mode is as a dictionary for looking up both English and
Japanese words. You can also add other dictionaries to Kiten’s list.

Kiten uses Jim Breen’s Edict and Kanjidic as the default dictionaries. You can
find more information at the Edict web site and the Kanjidic web site.

2.1 Looking Up Words

To look up words in either language, type them in to the text-edit (much like
Konqueror’s location bar) and press either Enter or the Search button on the
toolbar (again, much like Konqueror). Kiten will then look up the word.

You can enter Kanji, Kana and English and get back results from Kiten. These
results of your search will appear in the large results view which takes up the
majority of the Kiten window.
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2.1.1 Filtering

Often times you will want to filter rare words from your search. Kiten will do
this for you if toggle Settings→ Filter Rare.

NOTE
Not all dictionary files support filtering rare entries - most dictionaries, excluding the
two provided by default in Kiten do not.

If you have not enabled filtering rare entries, common entries will be labeled
Common in the result view.

2.2 Advanced Searches

Kiten supports more advanced searches than plain normal word searches.

2.2.1 Options for Matching English

Case sensitivity and whole-word matching can be enabled or disabled by choos-
ing Settings→ Configure Kiten..., and then choosing the Searching item on the
list on the left. The options can be enabled by checking the check boxes and
disabled by unchecking the check boxes on this page. These options are global
and affect all searches.
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2.2.2 Beginning/Anywhere Searches

To search for the beginning of a word, instead of pressing the Search button on
the toolbar or pressing Return on the text-entry in the toolbar, choose Search→
Search with Beginning of Word. Similarly, choose Search→ Search Anywhere
to search for your text anywhere in a word. These search modes work for
searches of both languages.

2.2.3 Searching in Results

Kiten can also help you refine your searches by allowing you to search for new
text in the results generated by a previous search. To do this, just choose Search
→ Search in Results to perform your search.

2.3 Verb Deinflection

Kiten can deinflect verbs you search for. To enable this, make sure Settings→
Deinflect Verbs in Regular Search is checked. Kiten will then deinflect Japanese
you search for that starts with a Kanji and ends with a Kana.

The "Deinflect" option tries to unconjugate Japanese verbs. Deinflect only sup-
ports the common verb conjugations. If you search a lot of Japanese text you
might consider using this option until you get used to handling Japanese verb
forms.
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Chapter 3

Looking Up Kanji

Kiten has features that makes finding the one kanji you want easy from over
14,000 in the default dictionary.

NOTE
Clicking on any Kanji in the main result view will show details on that particular
Kanji. This can sometimes be the fastest way to look up a kanji.

TIP
Kanji searches are also filtered according to whether Settings→ Filter Rare is
checked.

3.1 Regular Searching

To enable regular searching on the Kanji dictionary, check Settings→ Kanjidic.

You can search with English and Japanese search strings the exact same way
you can with the normal dictionary.

CAUTION
When searching for Kana readings in the Kanji dictionary, you will have to put a
period before the okurigana (the kana that are not part of the Kanji).
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3.2 Radical Searching

You can use Kiten’s radical search dialog to search for Kanji with a combination
of radicals and a certain stroke count. Choose Search→ Radical Search... to
open the radical search dialog.

To choose the radicals you want to be in your Kanji, select them from the mid-
dle listbox. To display possible radicals to select from this listbox with a certain
number of strokes, choose this number of strokes from the spinbox just above
the listbox. The radicals you choose will appear in the listbox to the right.

To choose how many strokes your Kanji should have, first check the Search by
total strokes check box. (If you do not want to search by total strokes, uncheck
this check box.) Then select the number of strokes from the spinbox on the
left, under the check box. If you want the stroke count to be fuzzy by a certain
number of strokes, select the margin of error from the spinbox to the right of
the +/- label.

To perform the lookup, press the Look Up button.

3.3 Grade Search

To get a list of all Kanji in a certain grade, enter that grade in the main text-entry
in the toolbar. Then choose Search→Grade to perform your search.

TIP
You can enter Jouyou and Jinmeiyou to get Kanji not in a regular grade but in
those groups.

3.4 Stroke Search

To get a list of all Kanji with a certain number of strokes, enter that number
in the text-entry in the toolbar. Then choose Search→ Strokes to perform your
search.
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Chapter 4

Miscellaneous

This chapter describes miscellaneous features that can be used in both modes
in Kiten’s main window.

4.1 The History

Kiten keeps track of all of your queries in a list. You can see your last 20 results
by looking under Go→ History. To go forward one in the history, choose Go
→ Forward. To go backward one in the history, choose Go→ Back.

4.2 Inputting Japanese

If you are unable to input Japanese normally into KDE applications, you can
use Kiten’s Kana input system that is built in to the text-entry.

To start Kana input, press Shift+Space. Now inputted syllables will be trans-
formed into Hiragana. If you type a syllable in capital letters, it will be trans-
formed into Katakana instead. Press Shift+Space again to go back to regular
input.

4.3 Global Shortcuts

You can set global Kiten shortcuts that work everywhere on your desktop. Go
to the Kiten configuration dialog, which can be opened by choosing Settings
→ Configure Kiten.... Select the Global Keys section of the dialog. Here you
can set the keys for a global word search and a global Kanji search like in other
KDE shortcut configuration panels.
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4.4 Printing

You can print the result view by choosing File→ Print. Kiten will add an infor-
mative header to the printout.

4.5 Fonts

You can choose the font that Kiten uses in its result view and while printing.
Go to the Kiten configuration dialog, which can be opened by choosing Settings
→Configure Kiten.... Select the Font section of the dialog and select the font in
the font-chooser.

NOTE
QtTM 3’s new font-substitution system makes it so a Japanese font will always be
substituted for Japanese characters, even if the font you specify doesn’t include
them. Thus, you can choose any font in the chooser and everything should still
display fine.
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Chapter 5

Learn Mode

Kiten’s last mode is its Learn mode which is in a separate window. To open it,
choose File→ Learn....
The Learn mode window in turn has two main tabs - one where where you
maintain your ‘Learning List’, which is the list of Kanji that you are currently
trying to learn. The other tab is the quiz area, where you are given a never-
ending quiz on the Kanji on your Learning List.

TIP
If you want the Learn window to open every time you start up Kiten, check the Start
Learn on Kiten startup check box in the Learn section of the configuration dialog,
which can be opened by choosing Settings→ Configure Kiten....

5.1 The Learn Browser

The first tab of the Learn mode window, the List tab, provides an area to browse
the Kanji in the 8 Kanji grades - 1st-6th grade, Others in Jouyou, and Jinmeiyou.
Also in the top half of the tab is a listview which contains all of the Kanji on
your Learning List.

To choose a grade to browse, choose it from the list in Go→ Grade. After
selecting a grade, the first Kanji in that grade will be shown.

To go forward one Kanji in the current grade, choose Go→ Forward. To go
back one Kanji, choose Go→ Back. To go to a random Kanji, choose Go→
Random.

TIP
If you click on a Kanji in the top view, the main Kiten window will give detailed
information on the Kanji you clicked.
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5.2 Populating the Learning List

There are three ways to add Kanji to the Learning List. To add the current Kanji
(the one displayed in the view on the top) to your list, choose Edit→ Add. To
add all Kanji in the current grade to your list, choose Edit→Add All.

The current Kanji in the main Kiten window can also be added by choosing (in
the main Kiten window) File→Add Kanji to Learning List.

To delete a Kanji on your Learning List, select it and choose Edit→Delete. You
can also select a range of Kanji to delete by clicking in the list while holding
down the Shift or Ctrl keys.

5.3 Managing Learning List Files

Learning Lists can be saved to files for easy storage.

To open a list, choose File→ Open... and choose the existing list file in the file
dialog.

To open a new list, choose File→Open....

To save a list, choose File→ Save and choose the file to save your list to. To
save the list under a different filename, choose File→ Save As....

NOTE
When you close the Learn window the list you have opened will be re-opened the
next time you start Learn mode.

To print out your Learning List, choose File→ Print.

5.4 Quizzing

The second tab of the Learn window is the Quiz tab. If you have at least two
Kanji on your Learning List, this tab will be enabled. Click on the tab to switch
to it.
To answer the question, click on the pushbutton that contains the answer that
matches with the Kanji on the centered pushbutton.

If you do not know the answer, you can cheat by choosing Go→ Cheat. This
will set the correct pushbutton’s focus.

TIP
To see full information about the Kanji, click on the button it is drawn on. This will
be counted as a wrong answer, however, in the same way as if you cheated.

10



The Kiten Handbook

If you choose the wrong answer, or cheat, your score for that Kanji will be
decremented. If you choose the correct answer, your score will be incremented
by two. Your score on the Kanji are shown on the very right-hand column of
your Learning List (on the List tab of the Learn window).

NOTE
Your scores are stored globally for each Kanji - thus, the same Kanji in two different
files will always have the same score.

5.5 Configuring Quizzing

You can change the way quizzing works in the Kiten configuration dialog,
which can be opened by choosing Settings→ Configure Kiten.... Go to the
Learn section, and look at the Quizzing groupbox. Here you can change whether
the Kanji, meaning, or reading is given for the clue, and what is given for you
to guess on.
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Chapter 6

Credits and Licenses

Kiten copyright 2001, 2002 Jason Katz-Brown

DEVELOPERS

• Jason Katz-Brown jason@katzbrown.com

• Neil Stevens neil@qualityassistant.com

• Jim Breen jwb@csse.monash.edu.au - Wrote xjdic, of which Kiten borrows
code, and the xjdic index file generator. Also is main author of edict and
kanjidic, which Kiten essentially require.

• Paul Temple paul.temple@gmx.net - Port to KConfig XT and bug fixing.

Documentation copyright 2002, Jason Katz-Brown

This documentation is licensed under the terms of the GNU Free Documenta-
tion License.
This program is licensed under the terms of the GNU General Public License.
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